OpenHaptics v3.0 para win32 e x64 Windows 7, Vista e XP

Hardware

  • Dual Xeon® Pentium® IV 2.4 GHz ou processador melhor ou superior
  • Espaço livre no disco 512 MB
  • 2 GB RAM
  • Dependendo do modelo PHANTOM: Porta paralela (porta EPPMode integrada na placa mãe ou uma placa adaptadora paralela Axxon é recomendada) ou FireWire 1394a* ou um adaptador Ethernet compatível 10/100Mbps

Laptops

  • Interfaces não foram amplamente testadas em laptops
  • Em geral, a placa PCMCIA parece reter melhor conectividade do que os placas Express
  • Certifique-se de seguir as instruções do fabricante e use o driver mais atualizado para o cartão escolhido
  • Software: Windows® XP-32 (SP3), XP-64 (SP2), Vista-32 (SP2), Vista-64 (SP2) ou Windows 7, (win32 ou x64)
  • Compiladores: Microsoft® Visual C++ 2005 (SP2) ou Visual C++; 2008 ou Visual C++ 2010
  • Talvez necessite de bibliotecas de utilitários HDU e HLU de recompilação
  • Drivers: Driver do dispositivo PHANTOM v5.1.7 ou posterior
  • Um dos dispositivos hápticos PHANTOM compatíveis. Os dispositivos PHANTOM Premium com base em PCI não são compatíveis.
  • PHANTOM Omni (FireWire IEEE 1394a)*
  • PHANTOM Desktop (Porta paralela ou Porta LAN)
  • PHANTOM Premium 1.0, 1.5, 1.5 High Force, 3.0 (Porta paralela ou porta LAN)
  • PHANTOM Premium 1.5/6DOF, 1.5HF/6DOF, 3.0/6DOF (Porta paralela)
  • OBSERVAÇÃO: o Conversor de Comunicação PHANTOM (PCC) está disponível para dispositivos de Porta paralela para uso com interface FireWire.

OpenHaptics v3.0 para Linux

Hardware

  • Dual Xeon® Pentium® IV 2.4 GHz ou processador melhor ou superior. Para fazer interface com os dispositivos Sensable Desktop ou Premium, a porta paralela de modo EPP integrada à placa mãe é necessária.
  • 512 MB de espaço no disco e 2 GB RAM.

Software

  • Ubuntu 11.1 e Fedora 16 (ou posterior)
  • Kernel 3.3.0 ou superior
  • Mesa-OpenGL® com interface GLX ao X Window System®. Certifique-se de que "glxgears" pode ser executado em seu sistema
  • Kit de ferramentas de utilitários GLUT-OpenGL
  • Biblioteca de widgets MesaGLw-Mesa. Requer ligações Motif (integrado com ./configure --enable-motif)
  • Mecanismo de fonte FreeType2-Portable (http://www.freetype.org)
  • Compiladores: gcc 4.x
  • Drivers: drivers do dispositivo PHANTOM v 4.3-2* ou superior

* Para encontrar a versão do kernel, digite "uname -r" no terminal. Para perguntas adicionais, verifique os documentos on-line na Central de Suporte ao Desenvolvedor (http://dsc.sensable.com) ou publique perguntas nos fóruns do desenvolvedor.

Um dos modelos PHANTOM compatíveis

  • PHANTOM Omni (FireWire IEEE 1394a)*
  • PHANTOM Desktop (Porta paralela)
  • PHANTOM Premium 1.0, 1.5, 3.0 (Porta paralela)
  • PHANTOM Premium 1.5/6DOF, 3.0/6DOF (Porta paralela)

As seguintes configuração NÃO são compatíveis:

  • Dispositivos High Force PHANTOM Premium
  • Conversor de Comunicação PHANTOM
  • Configurações Dual PHANTOM
  • Dispositivos PHANTOM Premium com base em PCI

Disponível para download na Central de Suporte ao Desenvolvedor do Sensable (DSC)

* O dispositivo PHANTOM Omni está em conformidade com o IEEE 1394a. Entretanto, a Sensable está ciente de que clientes enfrentaram dificuldades de desempenho com os dispositivos PHANTOM ao usar as placas controladoras com determinadas determinações de driver ou conjunto de chip IEEE 1394a. Nesses casos, talvez seja necessário atualizar ou alterar o driver da placa controladora 1394 ou tentar usar uma placa controladora 1394 complementar.

A operação e o controle adequados do Haptic Servi Loop necessitam de desempenho "em tempo real" suficiente do computador host. No Windows, para medir a latência do sistema no computador, use o DPC Latency Checker, disponível no site da TheSyCon. Se as barras vermelhas aparecerem com frequência superior a 5 a 7 segundos, considere atualizar a BIOS, o firmware do conjunto de chip, os dispositivos do sistema e outros drivers de dispositivos.

Essa atualização do sistema de baixo nível também pode ser necessária em casos em que o FireWire ou Comunicação paralela com o dispositivo PHANTOM falhe ou seja inconsistente ou intermitente, ou quando todo o sistema operacional tiver sido atualizado, por exemplo, do Windows XP para o Windows 7.

Fórum do Desenvolvedor do OpenHaptics

Verifique o fórum do desenvolvedor do SDK do Open Haptics aqui.